Hi,
Somewhere in these 14000+ lines, these:
- PUSER_OBJECT_HDR hdr;
+ PUSER_OBJECT_HDR* ppHdr;
"naming" changes are going to turn into bugs. I can only see 1000 lines
of your patch, and I can already see it's more then just "naming
changes". You changed a "pointer" to a "pointer of a pointer".
From
experience, I can tell you that somewhere in those 14000 lines, there's
a place where you forgot to change the dereference to match the new
definition. But how can I ever check? The diff isn't posted here, and
doing it manually would waste my time. And it also shows me that this
patch probably has a lot more then "naming" changes.
This is as of now, I think the 4th or 5th gigantic patch in this branch with
1) Dubious changes
2) Changes stuck together (naming changes with code changes, etc)
3) Still no changelog.
I am voicing my public disagreement/outcry with the way this branch is
being handled.
gdalsnes(a)svn.reactos.com wrote:
mostly naming changes
typedef struct _USER_REFERENCE_ENTRY
{
SINGLE_LIST_ENTRY Entry;
- PUSER_OBJECT_HDR hdr;
+ PUSER_OBJECT_HDR* ppHdr;
} USER_REFERENCE_ENTRY, *PUSER_REFERENCE_ENTRY;
*[truncated at 1000 lines; 13185 more skipped]*
Best regards,
Alex Ionescu