chorns(a)cvs.reactos.com wrote:
CVSROOT: /CVS/ReactOS
Module name: reactos
Repository: reactos/tools/
Changes by: chorns(a)mok.osexperts.com 04/10/28 12:02:01
Log message:
2004-10-28 Casper S. Hornstrup <chorns(a)users.sourceforge.net>
* drivers/net/tcpip/tests/setup.c: Include windows.h.
* lib/gdiplus/tests/setup.c: Ditto.
* lib/kernel32/tests/setup.c: Ditto.
* lib/ws2_32/tests/setup.c: Ditto.
* subsys/win32k/tests/setup.c: Ditto.
* ntoskrnl/tests/setup.c: Ditto.
* ntoskrnl/include/ntoskrnl.h: Include test.h.
* ntoskrnl/mm/virtual.c (NtLockVirtualMemoryInternal): New function.
(NtLockVirtualMemory): Use NtLockVirtualMemoryInternal.
Should we define a sort of "best practice" in inserting a little
"p"
after the subsystem prefix and before the proper function's o
structure's name, to mark the *p*rivate symbols, or use the "Internal"
suffix?
1) NtpLockVirtualMemory (MmpLockVirtualMemory)
2) NtLockVirtualMemoryInternal
IMHO, not only an aesthetics problem.
Option (1) means that any symbol in ntoskrnl/include have a "p" or
"P"
in their names.
* ntoskrnl/tests/Makefile (TARGET_CFLAGS):
Add -I../include.
* ntoskrnl/tests/stubs.tst: Remove stubs for functions in libgcc.
* regtests/shared/regtests.h: Make independent of windows.h.
* tools/helper.mk (run): Link with libgcc.
* tools/regtests.c (EXESTUB): Include windows.h.
* ntoskrnl/include/internal/test.h: New file.
* ntoskrnl/tests/tests/VirtualMemory.c: Ditto.
Emanuele
_______________________________________________
Ros-dev mailing list
Ros-dev(a)reactos.com
http://reactos.com:8080/mailman/listinfo/ros-dev
Thanks for bringing this up Emanuele!
I am strongly for using "p" for private, since that's what I've always
used, and that's also what MS uses. It's also a bit shorter.
In case anyone is interested, here are the best practices from Microsoft:
Cc->None
Ex->Exp
Dbg->Dbgk
FsRtl->FsRtlp
Hal->Halp
Io->Iop
Ke->Ki
Lpc->Lpcp
Ldr->Ldrp
Mm->Mi
Nt->None
Ob->Obp
Rtl->Rtlp
Se->Sep
Vf->Vi
Wmi->Wmip
Zw->None
Best regards,
Alex Ionescu