Sorry but these kinds of fixes are not "readability fixes", in fact they make things more obtuse.

(*MdlPages << PAGE_SHIFT)) could be interpreted as

*(MdlPages << PAGE_SHIFT).

while

((*MdlPages) << PAGE_SHIFT)

Makes it clear what is happening.

In general, all operations affecting the contents of a *dereference should be in parens.

Best regards,
Alex Ionescu


On Sun, Sep 11, 2011 at 7:47 AM, <tfaber@svn.reactos.org> wrote:
-                                  ((*MdlPages) << PAGE_SHIFT));
+                                  (*MdlPages << PAGE_SHIFT));