On 2013-05-13 15:05, ekohl(a)svn.reactos.org wrote:
Status =
NtReplyWaitReceivePort(AuthPortHandle,
(PVOID*)&LogonContext,
- &ReplyMsg->h,
- &RequestMsg.h);
+ (PPORT_MESSAGE)ReplyMsg,
+ (PPORT_MESSAGE)&RequestMsg);
As the Guy Who Officially Hates Casts™, I have to ask: wasn't the
previous version better for type safety? With the cast, an additional
[or missing] & can slip in and the code will compile without complaint.
Best,
Thomas