Does it really matter if people enable it or not if we still provide the functionality?
/Johannes Olofsson
> Till: ReactOS Development List <ros-dev(a)reactos.org>
> Rubrik: Re: [ros-dev] Patent on FAT
> Datum: Wed, 11 Jan 2006 14:57:50 -0500
> Hi,
>
> I think we should turn off the 8.3 short filename support by default
> and see what breaks. Providing a option right at the start of 2nd
> stage step "Patented features" using a checkbox to enable it should
> get us around the issue. Its not our problem if someone else enables
> it.
>
> --
> Steven Edwards - ReactOS and Wine developer
>
> "There is one thing stronger than all the armies in the world, and
> that is an idea whose time has come." - Victor Hugo
>
> _______________________________________________
> Ros-dev mailing list
> Ros-dev(a)reactos.org
> <a
> href=http://www.reactos.org/mailman/listinfo/ros-dev>http://www.reactos.org/
> mailman/listinfo/ros-dev</a>
nitro2k01 wrote:
> I haven't seen the patant documents, but doesn't this mean that any
> file system which stores both long and short file names on the same
> volume would be theoreticlly affected?
>
No. Long files names were incorporated into unix systems long before the
days FAT, or even DOS.
This patent (if correct) is linked to FAT only.
If is true, it would effect many things, but I can't see Microsoft enforcing
it, it would alienate themselves.
Just the fact that it is there is a problem for ReactOS though, even if they
don't do anything about it.
I haven't been able to find a copy of the patent yet. AFAIK, it was only
released today.
Ged.
************************************************************************
The information contained in this message or any of its
attachments is confidential and is intended for the exclusive
use of the addressee. The information may also be legally
privileged. The views expressed may not be company policy,
but the personal views of the originator. If you are not the
addressee, any disclosure, reproduction, distribution or other
dissemination or use of this communication is strictly prohibited.
If you have received this message in error, please contact
postmaster(a)exideuk.co.uk
<mailto:postmaster@exideuk.co.uk> and then delete this message.
Exide Technologies is an industrial and transportation battery
producer and recycler with operations in 89 countries.
Further information can be found at www.exide.com
I've seen this bugcheck several times debugging various things. At
the moment, it reproducible following the steps in the bug. This has
been around for a while and it aid me greatly to have it fixed.
http://www.reactos.org/bugzilla/show_bug.cgi?id=1263
WD
--
<Alex_Ionescu> it's like saying let's rename Ke to Kernel because
people think it's Ketchup
Murphy, Ged (Bolton) wrote:
>
> I'm reading reports of a US patent on FAT.
>
Link:
http://news.com.com/Microsofts+file+system+patent+upheld/2100-1012_3-6025447
.html?part=rss&tag=6025447&subj=news
************************************************************************
The information contained in this message or any of its
attachments is confidential and is intended for the exclusive
use of the addressee. The information may also be legally
privileged. The views expressed may not be company policy,
but the personal views of the originator. If you are not the
addressee, any disclosure, reproduction, distribution or other
dissemination or use of this communication is strictly prohibited.
If you have received this message in error, please contact
postmaster(a)exideuk.co.uk
<mailto:postmaster@exideuk.co.uk> and then delete this message.
Exide Technologies is an industrial and transportation battery
producer and recycler with operations in 89 countries.
Further information can be found at www.exide.com
gedmurphy(a)svn.reactos.org wrote:
> + case NM_RCLICK:
you should use WM_CONTEXTMENU instead so the menus are also accessible
by using the keyboard.
- Thomas
I'd quite like to see the blog page integrated into the site and made to
look pretty.
I also think it might entice devs to start using the thing. At the moment
there is only about 4 people listed, and of those only Alex every actually
uses it.
Would developers make an effort to start blogging if it was 'spruced up'
and integrated?
If not, I think it should be removed as it looks a bit pitiful as it is and
gives the impression not much is going on (which is obviously not the case)
It doesn't always have to be development related stuff in there. Anything
interesting draws a crowd.
Ged.
************************************************************************
The information contained in this message or any of its
attachments is confidential and is intended for the exclusive
use of the addressee. The information may also be legally
privileged. The views expressed may not be company policy,
but the personal views of the originator. If you are not the
addressee, any disclosure, reproduction, distribution or other
dissemination or use of this communication is strictly prohibited.
If you have received this message in error, please contact
postmaster(a)exideuk.co.uk
<mailto:postmaster@exideuk.co.uk> and then delete this message.
Exide Technologies is an industrial and transportation battery
producer and recycler with operations in 89 countries.
Further information can be found at www.exide.com
I would have to agree with this.
ReactOS.Bugzilla(a)reactos.org wrote:
>http://www.reactos.org/bugzilla/show_bug.cgi?id=1264
>
>
>
>
>
>------- Additional Comments From gvg(a)reactos.org 2006-01-10 19:07 CET -------
>I'd prefer something along the lines of:
>
>FooBarFast:
> non-486 implementation
>
>FooBar486:
> 486 implementation
>
>FooBarInit:
> Store either FooBarFast or FooBar486 in FooBarPtr
>
>FooBarPtr:
> .long FooBarInit
>
> .global ExfFooBar
>ExfFooBar:
> jmp [FooBarPtr]
>
>No self modifying code, at the expense of an indirect jump
>
>
>
I was just taking a look at some ReactOS code this evening and it got
me thinking about what our general strategy for handling invalid
parameters is.
For example, in kernel32.dll there is a function DebugBreakProcess.
This function takes one parameter, a process handle.
This parameter is passed through the following list of functions
unchecked by any of them, until the final one will return a failure...
DebugBreakProcess
DbgUiIssueRemoteBreakIn
RtlCreateUserThread
RtlpCreateUserStack
ZwAllocateVirtualMemory
ObReferenceObjectByHandle
Now I know this isn't a security vulnerability, which is what I was
originally looking for, but it did make me think of the question of
where should bounds checking be added?
In this example, the process handle must be a value greater than zero.
Should this simple check be added to DebugBreakProcess, or all of the
above? Is there some sort of standard that everyone should work to?
e.g. should all functions check their own parameters. Sure it might
make it a little slower due to multiple checks but it would make
ReactOS very robust.
Any thoughts on this?
Martin
PS: Lack of activity recently had been due to uni. exams.
hbirr(a)svn.reactos.org wrote:
>
>- Defined KeIpiGenericCall. It is necessary for the smp build.
>
Hi,
It should be in the w32api DDK, not in the interal headers. Sorry for
removing it if this broke the build, I didn't notice on UP.
Best regards,
Alex Ionescu
It seems the old binutils versions don't have a problem with "cmpxchg8b" but
with "qword ptr". The patch below makes the code compile on older versions
again. Any objections to committing it?
I've created a bug 1264 for keeping track of the "no longer works on i486"
issue.
GvG
Index: ntoskrnl/ex/i386/fastinterlck_asm.S
===================================================================
--- ntoskrnl/ex/i386/fastinterlck_asm.S (revision 20747)
+++ ntoskrnl/ex/i386/fastinterlck_asm.S (working copy)
@@ -405,7 +405,7 @@
/* Get next pointer and do the exchange */
mov ebx, [eax]
- LOCK cmpxchg8b qword ptr [ebp]
+ LOCK cmpxchg8b [ebp]
jnz 1b
/* Restore registers and return */
@@ -449,7 +449,7 @@
lea ecx, [edx+0x10001]
/* Do the exchange */
- LOCK cmpxchg8b qword ptr [ebp]
+ LOCK cmpxchg8b [ebp]
jnz 1b
/* Restore registers and return */
@@ -489,7 +489,7 @@
mov cx, bx
/* Do the exchange */
- LOCK cmpxchg8b qword ptr [ebp]
+ LOCK cmpxchg8b [ebp]
jnz 1b
/* Restore registers and return */
@@ -623,7 +623,7 @@
mov edx, [edx+4]
/* Do the op */
- LOCK cmpxchg8b qword ptr [ebp]
+ LOCK cmpxchg8b [ebp]
/* Restore volatiles */
pop ebp
@@ -655,7 +655,7 @@
mov edx, [edx+4]
/* Do the op */
- LOCK cmpxchg8b qword ptr [ebp]
+ LOCK cmpxchg8b [ebp]
/* Restore volatiles */
pop ebp